Ошибка SSL соединения

Компьютерные сети и их настройка

Модератор: Tim308

Ответить
Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 23 авг 2017, 13:23

Не знаю в какой теме создать. Если тут не место перенесите пожалуйста в соответствующий раздел.

Суть проблемы в следующем. С недавнего времени у меня при переходе на некоторые страницы моего сайта возникают ошибки подключения. Происходит это потому, что в адресе подставляется порт 80, а так, как соединение по https протоколу, т.е порт 443, то браузеры отказываются соединяться.
Вот пример https://chudo-hata.pp.ua:80/forum/
Если убрать указание на 80 порт, то соединение происходит нормально. Я даже не знаю, в какую сторону копать. Никаких настроек я в последнее время не менял, ошибки стали появляться совсем недавно. Подскажите пожалуйста, что это может быть.

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 23 авг 2017, 15:32

tvq12, у вас форум? phpbb? Какой версии? Как вообще осуществляете смену протокола с http на https? редиректом? Если phpbb то что в настройках в админке на вкладке общие в пункте Настройки сервера -> Настройки URL сервера?

Отправлено спустя 1 минуту 27 секунд:
PS: Для принудительного редиректа в случае если web-сервер апач создайте в корне сайта файл .htaccess с содержанием

Код: Выделить всё

RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L]

Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 23 авг 2017, 16:26

У меня сайт (интернет магазин), ну и форум к нему. Дело в том, что всё работало нормально не один месяц, а тут вдруг началось такое. Я не менял абсолютно никакие настройки. На главную страничку заходит абсолютно нормально, по страницам сайта переходы без проблем, а вот заход на форум начал сбоить и в админке магазина есть функция сохранить заказ в формате pdf тоже при нажатии подсовывает 80 порт и, естественно, выдаёт ошибку.
.htaccess давно создан и исправно работал долгое время, ума не приложу, что случилось.

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 23 авг 2017, 19:52

хм... Если вы не меняли никаких настроек и не ставили никаких расширений ни на форуме ни на сайте, а также не трогали настройки web-сервера то вам прямая дорого в техподдержку хостинга. А вот если что-то таки делали то опишите что (даже если вы думаете что это никак повлиять не могло).

Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 23 авг 2017, 21:19

Не менял абсолютно ничего. Всё началось совсем недавно и сначала на компьютере с Win XP на браузере Яндекс. Я это связал с тем, что ХР уже не поддерживается и наверное вышло какое-то несовместимое обновление для браузера. Но потом проблема появилась и на компьютере с Win 7.
Скажите пожалуйста, у вас приведенная мною ссылка тоже подставляет порт 80 и не открывается?

Отправлено спустя 5 минут 25 секунд:
Точнее не так. Если зайти на https://chudo-hata.pp.ua а потом нажать ссылку "форум", то проблема у вас тоже возникает?

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 23 авг 2017, 21:31

tvq12 писал(а):
23 авг 2017, 21:19
Точнее не так. Если зайти на https://chudo-hata.pp.ua а потом нажать ссылку "форум", то проблема у вас тоже возникает?
Нет, все нормально. Проверил несколько раз в google chrome и microsoft edge.

Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 24 авг 2017, 21:48

Смотрите, как это выглядит у меня с Яндекс браузера и Firefox.
Ошибка 2.JPG
Ошибка 1.JPG

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 24 авг 2017, 23:42

Я заходил как не авторизированный пользователь, так что возможно поэтому проблема не проявилась... Но вы так и не ответили:
Повторю вопрос:

Что в настройках в админке на вкладке общие в пункте Настройки сервера -> Настройки URL сервера?

Отправлено спустя 3 минуты 11 секунд:
И еще - на той-же вкладке в пункте Настройки cookies у вас включены безопасные cookie?

Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 24 авг 2017, 23:52

Настройки URL выглядят так:
Форум.JPG
Безопасные cookie включены.
Но что-то мне подсказывает, что проблемы не в настройках, а в сертификате. Он автоматически продлевается каждые 3 месяца и последнее продление было с 16 августа, примерно тогда и начались проблемы. Хотя поставщик уверяет, что у них всё в порядке. Но ведь раньше всё работало, а настройки я не трогал это абсолютно точно.

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 25 авг 2017, 00:08

С настройками понятно, все верно.

А вы сами попробуйте открыть например в хроме режим инкогнито и зайти на свой сайт без cookie и кэша. Будет-ли проблема? А если потом в том-же режиме зайти на форум с учеткой?

PS: Ну и да, пинайте хостинг. Рас вы ничего не трогали то пусть они там сами ищут что изменилось.

Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 25 авг 2017, 12:06

Всё странно, я не понимаю где искать у хостера, у поставщика сертефиката или вообще не пойми где :cry:
В режиме инкогнито на форум попадаю без проблем. Залогинился и всё равно заходит нормально. Но на сайте скрипт "сохранить в режиме PDF" упорно выдаёт ошибку.

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 25 авг 2017, 14:21

Поставщик сертификата точно ни при чем. Проблема либо в настройках на сервере либо у вас есть какие-то скрипты... Кстати как вариант - возможно дело в настройках браузера или в его расширениях раз проблема не проявляется у меня.

Но мне крайне проблематично что-то подсказать т.к. я не знаю что у вас там за веб-сервер, как он настроен, какие модули на нем запущены и т.п. Могу только предполагать. Но опираясь на ваши слова что вы ничего не меняли, не обновляли и не ставили расширений ни на сайт ни на форум - проблема точно либо в хостинге либо в ваших настройках браузера.

Отправлено спустя 52 секунды:
PS: Хотя будь я на месте хостера я-бы вам на слова не верил т.к. симптомы очень похожи на конечные скрипты сайта а не на настройки хостинга!

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 25 авг 2017, 21:54

В личке выяснилось что проблема не в браузере tvq12.

tvq12, чтобы долго не мучатся попробуйте так: в !корневом! .htaccess файле после какой-нибудь строки RewriteRule добавьте следующие строки:

Код: Выделить всё

RewriteCond %{SERVER_PORT} 80
RewriteRule (.*) https://chudo-hata.pp.ua:443/$1
Код выше смотрит есть-ли в URL номер порта 80 (или открывается-ли сайт по http без указания 80-го порта) и если это так, то происходит редирект на https://chudo-hata.pp.ua:443/далее_любо ... тый_из_url (порт 443 в url не будет в адресной строке).

Попробуйте и отпишитесь о результате. Если не уверены куда вставлять то предоставьте весь текст из вашего htaccess и я подскажу.

Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 25 авг 2017, 23:18

Мой корневой .htaccess выглядит так:
<IfModule mod_setenvif.c>
SetEnvIf WSR-HTTPS 1 HTTPS=on
</IfModule>
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP:WSR-HTTPS} 1
RewriteRule .* - [E=HTTPS:on]
</IfModule>

AddType image/x-icon .ico
AddDefaultCharset UTF-8
Options +FollowSymlinks
Options -Indexes

<IfModule mod_rewrite.c>
RewriteEngine on
#RewriteBase /

#Перенаправление на www.site~
#RewriteCond %{HTTP_HOST} !^www.
#RewriteRule (.*) http://www.%{HTTP_HOST}/$1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f [OR]
RewriteCond %{REQUEST_URI} \.(ini|php)$
RewriteRule ^(.*) index.php [L,QSA]
</IfModule>

<IfModule mod_php5.c>
php_flag magic_quotes_gpc Off
</IfModule>

# сжатие text, html, javascript, css, xml:
<IfModule mod_deflate.c>
AddEncoding gzip .gz
AddOutputFilterByType DEFLATE image/x-icon
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE application/rss+xml
BrowserMatch "MSIE [456]" no_gzip dont-vary
BrowserMatch "SV1;" !no_gzip !dont-vary
BrowserMatch "Opera" !no_gzip !dont-vary
BrowserMatch "Firefox/[0-3]\." gzip-only-text/html
BrowserMatch "Firefox/3\.[1-9]" !gzip-only-text/html
BrowserMatch "Chrome/2" gzip-only-text/html
BrowserMatch "Safari" gzip-only-text/html
BrowserMatch "Konqueror" gzip-only-text/html
</IfModule>

#кеширование в браузере
<IfModule mod_expires.c>
<FilesMatch ".(jpg|jpeg|png|gif|swf|ico|css|js)$">
ExpiresActive On
ExpiresDefault "access plus 5184000 seconds"
</FilesMatch>
</IfModule>

<IfModule mod_headers.c>
<FilesMatch ".(jpg|jpeg|png|gif|swf|ico|css|js)$">
Header set Cache-Control "max-age=5184000, public, must-revalidate"
Header unset ETag
FileETag None
</FilesMatch>
</IfModule>
# DO NOT REMOVE THIS LINE AND THE LINES BELOW HOTLINKID:GeNyhyzepe
RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?chudo-hata.pp.ua/.*$ [NC]
RewriteRule .*\.(.*)$ http://chudo-hata.pp.ua [R,NC]
# DO NOT REMOVE THIS LINE AND THE LINES ABOVE GeNyhyzepe:HOTLINKID

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 5146
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 189
Репутация: 595
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Ошибка SSL соединения

Сообщение DesignerMix » 25 авг 2017, 23:32

tvq12 писал(а):
25 авг 2017, 23:18
Мой корневой .htaccess выглядит так:
После строки RewriteRule .* - [E=HTTPS:on] добавьте то, что я написал выше.

Аватара пользователя

Автор темы
tvq12
Постоянный пользователь
Сообщения: 101
Зарегистрирован: 16 ноя 2015, 17:02
Репутация: 4
Статус: Не в сети

Ошибка SSL соединения

Сообщение tvq12 » 27 авг 2017, 10:12

Попробовал. К огромному сожалению не помогло. Кроме всего прочего в админке появились другие глюки. Вернул всё, как было. Буду пытаться писать хостеру, хотя не верю в эту затею. Да и если честно манипуляции с портом через .htaccess это же костыли, а хотелось бы устранить причину. Пока вручную убираю указание на 80 порт, когда надо использовать функцию "сохранить в PDF"
Огромное спасибо за желание помочь.

Ответить

Вернуться в «Сетевые технологии»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость