Проблема при обновлении phpBB до версии 3.1.9 ✓ ЕСТЬ ОТВЕТ

Здесь обсуждается форумный движок phpBB различных версий. В дальнейшем, если понадобится, форум будет вынесен в отдельный подраздел и разбит на категории.
Ответить

Автор темы
Oleko
Новичок
Сообщения: 9
Зарегистрирован: 18 окт 2015, 11:13
Репутация: 0
Статус: Не в сети

Проблема при обновлении phpBB до версии 3.1.9

Сообщение Oleko » 24 сен 2016, 16:35


Здравствуйте. Пытался обновить phpBB до 3.19, сделал всё по интсрукции - скачал папки install и vendor для автоматического обновления, запустил из админки обновление и получил вот такое Fatal error: Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/u108981/olekoru/www/docs/forum/includes/startup.php on line 170 Подскажите, как исправить?

ЛУЧШИЙ ОТВЕТ DesignerMix » 24 сен 2016, 19:54
Oleko писал(а):Источник цитаты Сейчас у меня 3.16.

Чтобы обновиться с 3.1.6 до 3.1.9 используйте этот пакет автоматического обновления - https://www.phpbb.com/files/release/php ... _3.1.9.zip

На всякий случай - Инструкция по использованию пакета автоматического обновления phpBB

Отправлено спустя 1 минуту 10 секунд:
PS: Всегда делайте BackUP файлов и БД перед обновлением!
ПЕРЕЙТИ К ПОЛНОМУ СООБЩЕНИЮ ➙
Последний раз редактировалось DesignerMix 24 сен 2016, 16:49, всего редактировалось 1 раз.
Причина: Не пишите в чужих темах!!!

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 4482
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 172
Репутация: 549
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Проблема при обновлении phpBB до версии 3.1.9

Сообщение DesignerMix » 24 сен 2016, 16:55


Oleko, с какой версии вы обновлялись на 3.1.9? Вы уверены что скачали нужный пакет автоматического обновления? Вы точно скопировали все файлы и папки заменив уже имеющиеся на форуме?


Автор темы
Oleko
Новичок
Сообщения: 9
Зарегистрирован: 18 окт 2015, 11:13
Репутация: 0
Статус: Не в сети

Проблема при обновлении phpBB до версии 3.1.9

Сообщение Oleko » 24 сен 2016, 19:13


Михаил, добрый вечер. Скачал отсюда https://www.phpbb.com/downloads/?mode=update&version= 3.18 Сейчас у меня 3.16. Распаковал папку install и папку vendor очистил и заменил все файл из скаченного архива. Надо последовательно обновляться от 3.16 - 3.17 - 3.18? И как быть с русским языком, может надо русский пак скачать?

Отправлено спустя 3 минуты 20 секунд:
Пытался делать по инструкции :)
Вложения
phbb2.jpg
phbb1.jpg

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 4482
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 172
Репутация: 549
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Проблема при обновлении phpBB до версии 3.1.9

Сообщение DesignerMix » 24 сен 2016, 19:54


Oleko писал(а):Источник цитаты Сейчас у меня 3.16.

Чтобы обновиться с 3.1.6 до 3.1.9 используйте этот пакет автоматического обновления - https://www.phpbb.com/files/release/php ... _3.1.9.zip

На всякий случай - Инструкция по использованию пакета автоматического обновления phpBB

Отправлено спустя 1 минуту 10 секунд:
PS: Всегда делайте BackUP файлов и БД перед обновлением!


Автор темы
Oleko
Новичок
Сообщения: 9
Зарегистрирован: 18 окт 2015, 11:13
Репутация: 0
Статус: Не в сети

Проблема при обновлении phpBB до версии 3.1.9

Сообщение Oleko » 26 сен 2016, 10:15


Михаил, большое спасибо. :super: Всё получилось. Если что, на будущее - где брать и как правильно выбирать обновления?

Аватара пользователя

DesignerMix
Администратор
Администратор
Сообщения: 4482
Зарегистрирован: 25 апр 2014, 10:51
Есть ответ: 172
Репутация: 549
Откуда: Белгород
Контактная информация:
Статус: Не в сети

Проблема при обновлении phpBB до версии 3.1.9

Сообщение DesignerMix » 26 сен 2016, 10:35


Oleko, Заходите сюда - https://www.phpbb.com/downloads/ переходите на вкладку AUTOMATIC UPDATE далее из выпадающего списка выбираете текущую версию и действуете по инструкции на которую я дал ссылку выше.

Отправлено спустя 24 секунды:
PS: Отметил тему решенной.