kali linux vpn-network-manager

Делимся опытом использования Linux

Модератор: Tim308

Ответить

0
Голосов нет
 
Всего голосов: 0

dokker
Новичок
Сообщения: 2
Зарегистрирован: 02 сен 2016, 22:21

kali linux vpn-network-manager

Сообщение dokker » 02 сен 2016, 22:28

Доброго времени суток ) подскажите как установить openvpn и network-manager??? ) как только не пытался не выходит не черта

Код: Выделить всё

[email protected]:~# sudo apt-get install openvpn
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
openvpn is already the newest version (2.3.8-1).
openvpn установлен вручную.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
[email protected]:~# sudo apt-get install network-manager-openvpn-gnome
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет network-manager-openvpn-gnome недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «network-manager-openvpn-gnome» не найден кандидат на установку
[email protected]:~# sudo openvpn --config openvpn-fe086b33-e616-4d94-92b6-8497278eb356.conf
Options error: In [CMD-LINE]:1: Error opening configuration file: openvpn-fe086b33-e616-4d94-92b6-8497278eb356.conf
Use --help for more information.
[email protected]:~# aptitude -r install network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome strongswan-nm network-manager-vpnc network-manager-vpnc-gnome
bash: aptitude: команда не найдена
[email protected]:~# 
[email protected]:~# nano /etc/NetworkManager/NetworkManager.conf
[email protected]:~# apt-get install network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет network-manager-pptp недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

Пакет network-manager-openvpn-gnome недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

Пакет network-manager-vpnc-gnome недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

Пакет network-manager-pptp-gnome недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Не удалось найти пакет network-manager-openvpn
E: Для пакета «network-manager-openvpn-gnome» не найден кандидат на установку
E: Для пакета «network-manager-pptp» не найден кандидат на установку
E: Для пакета «network-manager-pptp-gnome» не найден кандидат на установку
E: Не удалось найти пакет network-manager-strongswan
E: Не удалось найти пакет network-manager-vpnc
E: Для пакета «network-manager-vpnc-gnome» не найден кандидат на установку
[email protected]:~# apt
apt 1.1.10 (amd64)
Usage: apt [options] command

apt is a commandline package manager and provides commands for
searching and managing as well as querying information about packages.
It provides the same functionality as the specialized APT tools,
like apt-get and apt-cache, but enables options more suitable for
interactive use by default.

Most used commands:
  list - показать список пакетов из указанных имён пакетов
  search - искать в описаниях пакетов
  show - показать дополнительные данные о пакете
  install - установить пакеты
  remove - удалить пакеты
  autoremove - автоматически удалить все неиспользуемые пакеты
  update - обновить список доступных пакетов
  upgrade - обновить систему, устанавливая/обновляя пакеты
  full-upgrade - обновить систему, удаляя/устанавливая/обновляя пакеты
  edit-sources - редактировать файл с источниками пакетов

See apt(8) for more information about the available commands.
Configuration options and syntax is detailed in apt.conf(5).
Information about how to configure sources can be found in sources.list(5).
Package and version choices can be expressed via apt_preferences(5).
Security details are available in apt-secure(8).
                    В APT есть коровья СУПЕРСИЛА.
[email protected]:~# -
bash: -: команда не найдена
[email protected]:~# get update && apt
bash: get: команда не найдена
[email protected]:~# -
bash: -: команда не найдена
[email protected]:~# get dist
bash: get: команда не найдена
[email protected]:~# -
bash: -: команда не найдена
[email protected]:~# apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
[email protected]:~# aptitude -r install network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome
bash: aptitude: команда не найдена
[email protected]:~# su
[email protected]:~# apt-get install network-manager-openvpn-gnome
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет network-manager-openvpn-gnome недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «network-manager-openvpn-gnome» не найден кандидат на установку
[email protected]:~# aptitude -r install network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome
bash: aptitude: команда не найдена
[email protected]:~# 

Аватара пользователя
DesignerMix
Администратор
Администратор
Сообщения: 6660
Зарегистрирован: 25 апр 2014, 10:51
Откуда: Белгород
Контактная информация:

kali linux vpn-network-manager

Сообщение DesignerMix » 02 сен 2016, 23:42

Добавьте в source.list нужные источники и обновите список как указано в этой теме - https://forums.kali.org/archive/index.php/t-4382.html

Ответить

Вернуться в «Linux»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей